Приложение Google Messages перестанет работать на несертифицированных Android-устройствах в марте

Приложение Google Messages стало очень популярным среди пользователей Android-устройств благодаря своей широкой функциональности, включающей поддержку RCS-сообщений и удобный веб-клиент. Теперь стало известно, что поисковый гигант планирует запретить его работу на несертифицированных Android-устройствах.

Приложение Google Messages перестанет работать на несертифицированных Android-устройствах в марте

Чтобы устройство, работающее под управлением операционной системы Android, официально считалось Android-устройством, оно должно пройти сертификацию Google перед выпуском. Сертифицированные устройства поставляются с предустановленным набором сервисов Google и магазином приложений Google Play. Ранее на несертифицированные смартфоны можно было установить сервисы Google вручную, пока два года назад компания не запретила вход в учётную запись Google с таких аппаратов. Теперь в коде приложения Google Messages были обнаружены строки, содержащие уведомление о том, что с 31 марта оно перестанет работать на несертифицированных устройствах. Впрочем, такие смартфоны встречаются нечасто, однако ярким примером являются устройства Huawei, выпущенные после вступления в силу американских санкций против компании. По всей видимости, с 31 марта их владельцы лишатся возможности использовать Google Messages.

Приложение Google Messages перестанет работать на несертифицированных Android-устройствах в марте

Одной из возможных причин этого изменения может стать недавнее добавление сквозного шифрования в приложение. В прошлом году Google заявила, что владельцам телефонов Huawei не следует использовать модификации сервисов Google от сторонних разработчиков, поскольку несертифицированные устройства не прошли проверку безопасности. Это значит, что зашифрованные сообщения на этих устройствах потенциально могут быть скомпрометированы.

Источник

Метки записи:   ,
Оставьте комментарий к этой записи ↓

Ваше имя *

Ваш email *

Ваш сайт

Ваш отзыв *

* Обязательные для заполнения поля